Studio Menu Reference

StreamBase Studio adds entries to the Eclipse menus. As with all Eclipse menus, the available menu entries change, based on the perspective or editor you are currently using.

Some menu entries also have keyboard equivalents. When a keyboard shortcut is available, it is displayed after that menu entry.

The following sections describe only the entries added by StreamBase Studio in the Eclipse menu, or clarify an Eclipse menu's behavior in StreamBase Studio. For menu entries not discussed here, consult the Eclipse Help.

File Menu

New

Allows you to create a new StreamBase resource, as well as standard Eclipse resources.

Open File

Opens a selected file in your file system, using the program associated with the file in your system. For example, a CSV file might be opened in your favorite text editor. StreamBase files generally have specialized editors.

Switch Workspace

Allows you to specify an alternate workspace. When selected, StreamBase Studio closes and reopens using the specified workspace. Use alternate workspaces to organize projects into groups that share resources.

Import

Opens the Eclipse Import dialog. The StreamBase section of the import source tree allows you to import projects from a file system or the StreamBase Component Exchange. See Importing into Studio.

Export

Opens the Eclipse Export dialog. The StreamBase section allows you to export the current application to a StreamBase application bundle. See Exporting from Studio.

Load StreamBase Sample

Opens the Load Sample Projects dialog, which allows you to import sample StreamBase projects. See Loading Samples in Studio.

Load StreamBase Framework

Opens a StreamBase framework, if any are installed as add-on packages.

StreamBase Component Exchange

Opens a dialog that allows you to download StreamBase applications, libraries, utilities, and components from the StreamBase Component Exchange. See TIBCO StreamBase Component Exchange.

Exit

Closes StreamBase Studio.

Edit Menu

Select All

This option selects all components in the currently active editor.

The following entries are added to the Edit menu when you are editing in the StreamSQL Editor:

Show Tooltip Description (F2)

Shows the standard Eclipse pop-up description of the StreamSQL keyword under the cursor.

Word Completion

Completes a StreamSQL term when you have partially entered its name, if the remaining text is unambiguous. If the result is not satisfactory, try typing more text or using Content Assist.

Content Assist

In the StreamSQL Editor, shows a drop-down list of keywords and functions that you can choose to insert in a line of StreamSQL code. It may also display syntax and brief help for the current item. To select an item from the list, you can scroll to locate the desired item, or you can begin typing its name. The type ahead feature completes the item when it can do so unambiguously. If you have begun typing a word, Content Assist may complete the word without displaying a list, as with Word Completion.

Parameter Hints

Displays brief help if you hover your cursor over a function name in a StreamSQL statement.

Navigate Menu

Open StreamBase Resource

Opens the Open StreamBase Resource dialog. This dialog allows you to look up and open StreamBase-specific resources anywhere in your workspace, across all current projects in the workspace. The StreamBase resources included in the list are all StreamBase-related file types in the workspace.

You must type a search string before the list of resources is populated. Enter a single asterisk to show all resources in your workspace.

Project Menu

Build Automatically

Under most circumstances, leave this item checked. If checked, when you save an EventFlow or StreamSQL Editor editing session, that application and all StreamBase applications in your workspace are typechecked. When unchecked, automatic typechecking on save does not occur.

EventFlow Menu

This menu is only available when the EventFlow Editor has focus, and provides menu access to many of the functions provided by the StreamBase toolbar or the EventFlow context menu.

Align

When two or more components are selected on the EventFlow canvas, provides a submenu with six options for aligning the selected items on the canvas: Align Left, Align Center, Align Right, Align Top, Align Middle, Align Bottom.

Snap to Geometry

A toggle that enables the blue alignment lines that appear when moving a component icon on the canvas to help you align the component with adjacent ones.

Quick Outline

Opens a pop-up summary of the components in the current EventFlow — a faster alternative to the Outline view.

Module Call Hierarchy

Opens the Module Call Hierarchy view to examine the module calling order of the currently selected EventFlow module.

View Source

Displays a pop-up window showing the XML source of the current EventFlow module. If a single component is selected, the window contains the XML source code for that component only. If you select zero or multiple components, the entire application is shown.

Typecheck

Typechecks the current EventFlow or StreamSQL module. See Typechecking.

Automatically Typecheck

Toggles the state of automatic typechecking.

Center Selection

Centers the selected components in the current EventFlow Editor canvas.

Layout Application

Rearranges the EventFlow module's components and connections on the Editor canvas.

Zoom to Fit

Zooms the current EventFlow module in or out to fit the current Editor canvas.

Open Declaration

When a Module Reference is selected, opens the EventFlow file that defines that module. When the icon for a custom Java operator or adapter is selected, opens the Java source file for that Java operator or adapter, if the source is available in the current Studio workspace.

Extract as Module

Replaces the selected components in the current EventFlow module with a Module Reference, and creates a new module in the current project folder. See Extracting a Module.

Insert Menu

This menu is only available when the EventFlow Editor has focus. It provides a set of menu and keyboard-based alternatives to dragging and dropping components from the Palette View to the canvas. Notice that each item in the Insert menu lists a keyboard shortcut.

Run Menu

Stop StreamBase Application

Stops the currently running StreamBase application.

Run

By default, runs the currently selected EventFlow or StreamSQL application, or runs the launch configuration associated with the selected application, or re-runs the last-run configuration. The behavior of the Run button can be changed using WindowPreferences, then Run/DebugLaunching.

Run History

Provides a menu of recently run launch configurations.

Run As

When an EventFlow or StreamSQL application has the current focus, the Run As menu has one submenu, StreamBase Application that runs the currently selected EventFlow or StreamSQL application using Studio's default launch configuration. You can modify the default launch configuration using WindowPreferences, then Run/DebugLaunching.

Run Configurations

Opens the Eclipse launch configuration dialog, where you can create, edit, and run launch configurations for Eclipse-hosted applications, including StreamBase applications.

Debug, Debug History, Debug As, Debug Configurations

These options are the same as their Run counterparts, except that they run the selected application in debug mode, and allow you to specify a saved debug configuration.

External Tools

Provides tools to configure an Ant build, or to run another external build tool. This is an Eclipse feature not expected to be useful for StreamBase applications.

Window Menu

This menu is available in standard Eclipse. For a menu description see the Eclipse documentation on www.eclipse.org

However, StreamBase Studio users often have need of the settings in the Preferences menu item. The settings provide methods to manage the various views and perspectives in Eclipse, including those contributed by StreamBase Studio. See Studio Preference Settings for more information.

Help Menu

This menu provides help on using StreamBase and StreamBase Studio.

Welcome

Opens the StreamBase Welcome page.

Help Contents

Displays Help contents in an Eclipse Help window or external browser. The help contains books, topics, and information for StreamBase together with information about Eclipse-contributed components.

Search

Opens a Help view in which you can search the Help systems of all current Eclipse plug-ins. To narrow the search to include only StreamBase Help, use the Search scope control.

Dynamic Help

Opens a Help view to show help text for the currently active view, and dynamically updates as you switch among views.

Key Assist

View key bindings available for StreamBase Studio commands. To change a binding, select its name in the Key Assist list and press Shift+Ctrl+L

Tips & Tricks

Opens the Tips and Tricks dialog. Select StreamBase Studio to see a page of suggestions for using Studio. You can also view the tips and tricks pages for other Eclipse plug-ins.

StreamBase Expressions Guide

Opens the core reference document for StreamBase expression language features.

StreamBase Functions Guide

Opens the core function reference for the StreamBase expression language.

Cheat Sheets

Opens the Cheat Sheet Selection dialog, from which you can run a cheat sheet for StreamBase Studio or for other Eclipse plug-ins. A cheat sheet is an interactive tutorial that guides you through a demonstration or topic, step by step.

Check for Updates

This is an Eclipse feature not implemented for StreamBase Studio.

Install New Software

Accesses the Eclipse mechanism for installing and managing Eclipse plug-ins and updates. StreamBase Studio does not use this update mechanism.

About StreamBase Studio

Displays feature, license, and plug-in information about the current release of StreamBase. The Installation Details button, Configuration tab, displays informations about your running system and any current error condition. Use this when communicating with TIBCO Customer Support.