Installing on macOS

This page describes the installation of the TIBCO® Streaming base kit on Apple macOS platforms. The base kit for macOS includes the StreamBase Studio authoring environment, the StreamBase Runtime, and support files for the StreamBase and LiveView Client APIs.

TIBCO LiveView™ Desktop and its companion Desktop Workspace Manager are installed with a separate procedure, described in Installing LiveView Desktop.

Before You Install

Before you install TIBCO Streaming, use the following checklist to make sure each target machine matches the prerequisites.

    Read through the Release Notes for the current release to look for any late-breaking information about installing on macOS.
    If you have used StreamBase Studio on the target machine, back up your existing Studio workspace and configuration, as described below.
    Confirm that the target machine is running a supported version of macOS with the latest updates. See Supported Configurations.
    Confirm that the target machine's RAM and disk space requirements meet or exceed the minimums listed on Supported Configurations.
    Depending on where you decide to install StreamBase, you may need administrator and/or sudo rights on the target machine.
    For StreamBase release 10.3.0 and earlier, if you are running macOS 10.12 Sierra or later and you are having trouble getting StreamBase Studio 10.2 or 10.3 to start from its application bundle, see Starting StreamBase Studio on macOS Sierra. This issue is resolved as of StreamBase 10.4.0.
    The installation requirements of a JDK for command-line use are discussed in Installing a JDK.

Limitations and Differences

TIBCO StreamBase Studio™ is provided on macOS as a client application to allow users to develop, debug, and test StreamBase EventFlow and TIBCO LiveView applications. StreamBase installations on macOS include a local-only copy of the StreamBase Runtime for running and testing your applications locally, on the same Mac computer as Studio.

However, the StreamBase Runtime is explicitly not supported for build or production deployment purposes on Apple Mac machines.

Expect the following important differences when working with StreamBase Studio on macOS compared to Studio on Windows:

  • TIBCO strongly recommends using a two- or three-button mouse with StreamBase Studio on macOS. MacOS has strong support for two- and three-button mice based on its UNIX heritage.

    In many places, StreamBase documentation directs you to right-click to open the context menu. If you are using a two-button or three-button mouse on macOS, a right-click is invoked with the right mouse button as on other platforms (or with the left mouse button if you have configured for left handed use). If you are using a trackpad, use a light two-finger tap to invoke the context menu (depending on Trackpad Preference settings), or use control+click.

  • StreamBase Studio supports macOS's full screen feature.

  • There is no Insert key on Mac keyboards, but StreamBase Studio on Windows and Linux uses Insert to add a new row in schema editor grids in Properties views and configuration editors. On macOS, use the backslash key ( \ ) for this purpose. The backslash key retains its standard meaning in other contexts, including when composing an expression in a field of the schema editor grid.

  • Add-on products such as the High-Performance FIX Engine install as overlays into the same location as the base StreamBase kit. These packages are distributed as .archive-bin packages. On macOS, after downloading use chmod +x to be sure you can run the installer. See below for more.

  • StreamBase Studio keyboard shortcuts for Mac keyboards are not always explicitly called out in StreamBase documentation. In general, commands documented as Ctrl+key for Windows are accomplished with command+key on macOS.

  • On macOS, commands on the main StreamBase Studio menu and on context menus throughout Studio show the keyboard equivalent of commands using Mac keyboard symbols and semantics.

  • In StreamBase Studio, command+shift+L shows a pop-up help window of all commands and their keyboard equivalents just as Ctrl+Shift+L does on Windows.

  • StreamBase-specific EventFlow Editor keyboard shortcuts for Insert menu commands (such as O M to place a Map operator on the canvas) all work the same on macOS as on Windows.

  • Some menu items are in different places in keeping with macOS standards. In particular, when StreamBase documentation directs you to open Window>Preferences, on macOS open StreamBase Studio>Preferences, or use the macOS-specific keyboard equivalent command+comma.

  • StreamBase Studio Help opens in your system default web browser instead of opening in a separate application window as on Windows. The Help system in your browser is in Eclipse Help format with a left-side navigation panel and full search capabilities.

  • When you click a Show in Help link in the Properties view's Expression Quickref tab, a new browser tab opens for each click, instead of reusing an already-open Help tab as on Windows.

Back Up Existing StreamBase Workspace

If you used a previous release of StreamBase Studio on the target machine, create backup copies of your existing Studio workspace directories, before using StreamBase Studio in the current release. Save the backup copy with filenames that indicate the version number of the release you are archiving. For example, save SB-workspace-10-03-00.zip.

The default location of the StreamBase Studio workspace directory is described in Default Installation Directories. You may have specified a different directory the first time you ran StreamBase Studio.

Steps to Install StreamBase on macOS

TIBCO provides a StreamBase installer in standard Apple DMG (disk image) format. This installer includes a Java JDK for the exclusive use by TIBCO StreamBase software.

As downloaded from the TIBCO distribution site, the StreamBase DMG installer is delivered in a single file named according to the following pattern:

  • TIB_str_n.m.x_macosx_x86_64.dmg

where n.m.x is the release number. The macOS version is available for x86 64-bit only.

To install TIBCO Streaming, follow these steps:

  1. Double-click to open the downloaded DMG file.

  2. Click Agree to accept the StreamBase license. This opens the DMG folder on your desktop containing subfolders like the ones shown here.

    TIBCO Streaming n.m.x The TIBCO Streaming installation folder, where n.m.x is the current release number in major.minor.servicepack format. The inclusion of the full release number allows you to have more than one TIBCO Streaming release on your Mac at the same time (but using only one at a time). See Switching for details.
    doc Full documentation for this release in HTML format. This is a symbolic link to the /doc folder inside the TIBCO Streaming folder, which will be placed in your target installation folder. You can copy this folder to a public location to make StreamBase documentation available to other licensed users.
  3. As with all macOS program files, you are free to install StreamBase in any standard or personal location, as long as you have write access to the folder of choice. Decide on an installation location based on the following points:

    • Recommended. TIBCO recommends dragging the TIBCO Streaming n.m.x folder (or TIBCO Spotfire Data Streams n.m.x folder) to a folder named Applications in your home directory. Create the $HOME/Applications folder if it does not exist. This location is shown in examples on this page and is presumed throughout StreamBase documentation. The advantages of this location are:

      • The contents of home directory Applications folders are automatically included in macOS searches for application bundles, such as when using macOS Spotlight.

      • You automatically have write rights for any folder in your home directory, and can therefore install StreamBase add-on products with ease.

    • Also Possible. The standard location for macOS application files is /Applications at the root of the primary disk. This location has the advantage of being standard, but the disadvantage of requiring administrator access, both to install files initially, and to install other files to the same location later. These permissions issues can complicate the installation of StreamBase add-ons.

    • Linux-standard. TIBCO's standard installation location on Linux is /opt/tibco. The default installation location for the add-ons that use an installer in the .archive.bin format install by default into /opt/tibco/sb-cep/n.m. You can choose to drag the TIBCO Streaming folder to /opt/tibco to keep all your TIBCO products in the same location. However, the /opt folder does not exist by default on macOS machines, and rarely has write rights for all users by default.

  4. Drag the entire TIBCO Streaming n.m.x folder from the open DMG to the location you elected in the previous step. You may be prompted to enter an administrative password.

  5. To close the DMG folder, right-click or Control-click anywhere in its blank space to invoke the context menu, and select Eject.

Starting StreamBase Studio 10.3 on macOS Sierra

If you double-click the StreamBase Studio 10.2 or 10.3 icon in a Mac Finder window, but nothing happens — you probably installed StreamBase on macOS 10.12 Sierra or later.

This is a known issue described on the macOS Sierra workaround page, with several workarounds available.

This issue does not affect StreamBase Studio 10.4 and later.

Post-Installation Shell Configuration

For all users who will run or develop with TIBCO Streaming on this Mac, you must configure their shell initialization files such as .bash_profile. Follow the instructions in the macOS section of the StreamBase-Configured Shells page.

Installing Additional Features

For macOS, all add-on products and external adapters install as overlays into the base StreamBase folder. The installers for these add-ons are distributed as executable .archive-bin packages, which are standard .tar.gz files packaged in a shell wrapper.

These installers for macOS have file names that match the following patterns:

  • Adapters: TIB_sb-ad-name_version_macosx_64.archive-bin

  • Add-ons: TIB_sb-addin-name_version_macosx_x86_64.archive-bin

where version is the current release number in major.minor.servicepack format.

Note

The Safari browser on macOS automatically renames downloaded .archive-bin files as a safety precaution, because it detects that these files are unrecognized shell scripts. Safari adds the .txt extension so that these files are initially treated as text files.

When the download is complete, you must manually rename these files to remove the .txt extension.

After downloading one of these files, first make it executable with the chmod command. For example, for the TIBCO StreamBase Adapter for Apache Flume:

chmod +x TIB_sb-ad-flume_n.m.x_macosx_x86_64.archive-bin

For archive-bin packages, run the shell wrapper command. If you are installing into a StreamBase folder for which you do not have write privileges, run the command as root or with sudo:

cd /path/to/TIB_sb-ad-flume_n.m.x_macosx_x86_64.archive-bin
./TIB_sb-ad-flume_n.m.x_macosx_x86_64.archive-bin

The wrapper script displays a license file for you to agree to, then prompts for the full path to your base StreamBase installation. Provide the full absolute path; you do not need to escape the spaces in the folder name. For example, enter:

/Users/sbuser/Applications/TIBCO Streaming 10.4.0

or

/Users/sbuser/Applications/TIBCO Spotfire Data Streams 10.4.0

The script then unarchives its files into the STREAMBASE_HOME location you identified.

How to Start StreamBase Applications

On macOS, a StreamBase installation provides two GUI applications plus the command-line utilities listed in the Command Reference. Man pages are provided at the shell prompt for the command-line utilities.

The two GUI applications are named as follows on the macOS file system:

  • StreamBase Studio n.m.x.app

  • StreamBase Manager n.m.x.app

Double-click to start either of these .app bundles like any other Mac app.

Note

If you are running macOS Sierra or later, and double-clicking does not start the application, see Starting StreamBase Studio on macOS Sierra for some workarounds. These workarounds are not required for Studio 10.4.0 and later.

Switching Between StreamBase Releases

Because the name of the TIBCO Streaming installation folder in ~/Applications includes the release number, you can have more than one copy of StreamBase on your disk at the same time, and can switch back and forth between them to use one at a time.

The easiest way to do this is to use a symbolic link pointing to the actual StreamBase installation folder, and to place the path to the symbolic link's bin directory in the PATH, as recommended in Post-Installation Shell Configuration, above.

This way, when you have two or more StreamBase installations, you can quickly switch between them by re-creating the symbolic link to point to the desired version.

Uninstalling StreamBase on macOS

To uninstall StreamBase on macOS, just move the ~/Applications/TIBCO Streaming n.m.x folder (or TIBCO Spotfire Data Streams n.m.x folder) to the Trash, and remove any symbolic links you created. Your project files in your StreamBase Studio workspace are preserved when you remove the StreamBase application files.

Downgrading StreamBase Releases

When you upgrade from one StreamBase release to a new major release, on first run, StreamBase Studio automatically and silently upgrades the XML representation of your application files.

If you need to downgrade back to a previously used StreamBase release (such as to add a feature to an existing application), the older StreamBase Studio may not recognize some of the changes made to your applications by the newer Studio.

Thus, if you anticipate returning to an older StreamBase release, specify a separate workspace, and either start over with new projects in your new StreamBase Studio release, or restore your matching version-specific backup copies to the separate workspace. See above for instructions for backing up workspaces.