StreamBase Studio Eclipse Update Site

Downloading the StreamBase Eclipse Update Site

TIBCO Software Inc. formally supports and strongly recommends that you install and use the standalone TIBCO StreamBase® Studio included in your StreamBase installation kit. Nevertheless, for advanced Eclipse users, StreamBase also supports a plug-in version of Studio that you can install into your existing installation of Eclipse. Eclipse versions 4.5 and 4.6.2 are supported.

You install the plug-in version of StreamBase Studio from an Eclipse plug-in zip file that is structured the same way as an Eclipse update site. Download a zip file of the Eclipse update site from the TIBCO distribution site.

On the TIBCO eDelivery download page for TIBCO StreamBase software, select the Individual file download method.

The StreamBase Studio Eclipse Update package is delivered as a zip file named with the following pattern:

TIB_sb-cep_eclipseupdate_version_platform.zip

The following example shows the individual files you can download from a recent StreamBase release for Windows platforms:

If you need assistance, contact TIBCO StreamBase Technical Support to request access to the TIBCO distribution site.

What Is Provided

The Eclipse update site adds ONLY the StreamBase Studio authoring environment plug-ins to Eclipse. It does NOT provide:

  • The StreamBase deployment runtime for either EventFlow or LiveView fragment types.

  • Any sample files and projects.

  • Command-line utilities for querying and administering your servers.

  • Libraries, DLLs, JARs and other files to support using the StreamBase Client Library to develop client access programs.

The best use is to install both the Studio plug-ins in your own Eclipse and the full standalone StreamBase installation on the same machine. That way, the Studio-in-Eclipse edition can locate and use the StreamBase Server runtime and sample files provided only in the standalone version of Studio.

The plug-in folder is static and is designed to provide a snapshot of the Studio plug-ins at the time of each StreamBase release. To update your Studio plug-ins, you can run an additional installation of the plug-ins from the next StreamBase maintenance release, as described below in Upgrading Studio Plug-ins.

Be aware that the StreamBase Eclipse update site does not work the same as Eclipse update sites from the Eclipse Foundation or from other vendors. In particular, you cannot use the HelpCheck for Updates feature to obtain updated components. The update-site folder contains a snapshot of a single release of the plug-ins.

Platforms Supported

The StreamBase Studio 10.x Eclipse plug-ins are supported on the following platforms:

  • 64-bit Eclipse 4.5 or 4.6.2

    • Configured with the prerequisites described below

    • Running on a supported 64-bit installation of Microsoft Windows or macOS

The Studio 10.x plug-ins are developed against Eclipse 4.6.2 as the target platform. Eclipse 4.6.2 is the basis for the shipping StreamBase Studio in 10.1, and is thereby the preferred Eclipse version. However, the plug-ins also work with Eclipse 4.5.

Initial Conditions

To support the Studio plug-ins, your Eclipse installation must meet the following conditions:

  • Eclipse must already be running and working on a supported operating system.

  • You must be running Eclipse with a JDK, not just a JRE.

  • Eclipse must be running under a supported 1.8 version of an Oracle JDK. The ideal JDK version is the one shipped to support StreamBase Studio 10.x, as described the JDK row of the Supported Configurations table.

    Important

    When StreamBase Studio installs as a standalone product, it includes an Oracle JDK 1.8 for private use by Studio and StreamBase Server. This private JDK is not available when installing the Studio plug-ins into your own Eclipse, so you MUST make sure you are running Eclipse with a supported 1.8 JDK. The Studio plug-ins will not load if Eclipse is running with a 1.6 or 1.7 JRE or JDK.

  • The Eclipse JDK must be installed such that both java and javac commands are available on the search path of the logged-in username that will run Studio in Eclipse.

  • JDKs from vendors other than Oracle or Zing are not supported, and Oracle 1.6 or 1.7 JDKs are not supported for running Studio.

  • Eclipse must have all prerequisite features installed, as described in the next section.

Note

When installing the Studio plug-ins into Eclipse, TIBCO strongly recommends doing so while your machine has open access to the Internet, and with the Contact all update sites check box selected on the Available Software Install dialog.

Under these conditions, Eclipse automatically downloads and installs prerequisite components, which makes the upgrade process proceed smoothly and quickly.

Eclipse Prerequisites

The ideal Eclipse version to host the StreamBase Studio 10.x plug-ins is Eclipse 4.6.2. If you are installing the Studio plug-ins into another Eclipse version, you may need to adjust these instructions accordingly.

The StreamBase Studio Eclipse plug-ins require the following Eclipse components to be installed in advance.

— An Eclipse base installation

The recommended Eclipse 4.6.2 base kit is the following:

  • Eclipse for RCP and RAP Developers

Download the 64-bit version of this package, as appropriate for your target machine, from:

http://www.eclipse.org/downloads/packages/eclipse-rcp-and-rap-developers/neonrc2
— Java Development Tools (JDT) Feature

The JDT feature is always included in all Eclipse base kits.

— EMF Modeling Framework

The Eclipse base kit you start with, if other than the recommended Eclipse for RCP and RAP Developers kit, may already include the EMF Modeling Framework. Confirm its presence by opening HelpInstallation Details. Select the Plug-ins tab, and look for EMF Xcore in the Plug-in Name column. If EMF is already installed, skip now to install the GEF Editing Framework.

If your Eclipse base kit does not include EMF, then install the EMF Modeling Framework with the following steps:

  1. From your running Eclipse base kit, invoke HelpInstall New Software.

  2. In the Install dialog, select All Available Sites from the Work with drop-down list.

  3. Wait a few moments for the plug-in options list to fill in.

  4. Important! Clear the Group items by category check box.

  5. Important! Confirm that the Contact all update sites check box is selected.

  6. In the filter text field, type EMF and press Enter. Wait for the filtered results.

  7. From the resulting list, select EMF - Eclipse Modeling Framework Xcore Runtime.

  8. Click Next and go through the steps to accept the license, download, and install this feature.

  9. Restart Eclipse when prompted.

— GEF Editing Framework

Install the GEF Editing Framework, using the same steps as for EMF above, except substituting the following for steps 6 and 7:

  • In the filter text field, type GEF and press Enter. Wait for the filtered results.

  • From the resulting list, select Graphical Editing Framework GEF

Installing the Studio Plug-ins in Eclipse

When you have installed and configured Eclipse as described in the previous sections, follow the steps below to install the Studio 10.x plug-ins.

  1. Place the Eclipse update site package you downloaded above into a temporary folder. Do not unzip the downloaded update site package.

  2. Start your target Eclipse version.

  3. From the Eclipse main menu, invoke HelpInstall New Software.

  4. Make sure the Group items by category check box is selected.

  5. Click Add to add a software download site.

  6. In the Add Site dialog:

    1. Provide a name in the Name field, using the StreamBase release number. For example, enter StreamBase 10.1.0 Update Site.

    2. Click Archive and browse to the temporary folder containing the update site archive file and select it.

    3. Click OK.

  7. After reading the local update site zip file, Eclipse creates entries like the following in the Available Software grid:

  8. Select the check boxes next to TIBCO StreamBase Studio, TIBCO LiveView Studio Feature, and EventFlow Compare .sblayout File Loader for Subversive SVN.

    (If you have separately installed and use the Subclipse plug-in, select the remaining check box. Subclipse is not formally supported by StreamBase, but we do provide an .sblayout file loader for it.)

  9. Click Next and proceed through the steps to accept the license and download the plug-ins.

  10. If Eclipse prompts for permission to install the unsigned Studio plug-in files, click OK.

  11. Eclipse installs the Studio plug-ins into Eclipse.

  12. Restart Eclipse when prompted.

  13. When Eclipse restarts, a dialog prompts for permission to set Studio's location in the Eclipse preferences dialog.

    1. If you have a separate installation of StreamBase Studio 10.x on the same machine, click Yes to open the StreamBase Studio preference page.

    2. Specify the location of your existing StreamBase 10.x installation by clicking Browse and navigating to the top level folder of your installation.

    3. Click OK.

  14. On the Welcome page, click the arrow-shaped Workbench button in the upper right, or click the X on the Welcome tab to close the Welcome page and open the Eclipse workbench.

  15. Use WindowOpen PerspectiveOther to open the SB Authoring perspective.

What to Expect

Loading Studio into your own Eclipse is not meant to be an full alternative to a formal StreamBase Studio installation, but is made available as a convenience for experienced Eclipse developers. The following points describe the Studio-on-Eclipse configuration:

  • No license is required to run and develop applications on either StreamBase Studio or Studio-on-Eclipse.

  • The Studio-on-Eclipse configuration is most useful when installed on a machine that also has a licensed installation of StreamBase. You can run StreamBase applications on the licensed installation's StreamBase Deployment Runtime by specifying the location of the licensed installation in Studio-on-Eclipse's preferences.

  • The licensed installation on the same machine should be from the same release series as the Studio plug-ins on Eclipse, with the same major.minor release number.

  • Ideally, the StreamBase release number of your Studio-on-Eclipse plug-ins will have the same major.minor number as the remote Server. However, the StreamBase Deployment Runtime is somewhat forgiving of release numbers, and will try to run your application despite a release number skew.

Upgrading Eclipse Studio Plug-Ins

From Eclipse, you can upgrade the StreamBase Studio plug-ins by repeating the installation steps, using the Eclipse update site archive from a newer maintenance release on the same major.minor release branch.

As an example, let's say you originally downloaded the Update site zip file from the StreamBase 10.1.0 eDelivery site. You installed the Studio plug-ins into Eclipse as described in Installing the Studio Plug-ins above.

Now, release 10.1.1 comes along. Download and save the Eclipse update site zip file for the new release, using the same procedure described in Downloading.

Next, follow the same steps as in Installing for the new release. This time, however, Eclipse recognizes the plug-ins as updates for existing plug-ins, and lets you install the new release without having to uninstall first.

Installing Subversive Yourself

The Studio 10.x plug-ins include the Subversive team provider plug-in to provide access to files under the control of the Subversion version control system.

If, for any reason, you are installing Subversive on your own, you must also install the Subversive SVN JDT Ignore Extensions plug-in. Although it is marked as optional, this plug-in is essential to give Eclipse the knowledge of what file and directory names to ignore for certain purposes (such as any .svn directory) and what file extensions to consider source files.