LiveView Project Viewer

Overview

The LiveView Project Viewer presents a visual overview of a LiveView project, clarifying the relationships between the various components and providing easy access to the configuration information underlying each piece. The Viewer helps you navigate through and understand the components that make up a LiveView project, and provides a collection of wizards that walk you through the steps to create a new projects, or to add new components to existing projects.

The canvas area of the Project Viewer contains a directed graph, depicting how data flows through the various project components at run time. To create this graph, the Viewer scans the project's lvconf configuration files to discover the existing LiveView components and the interrelationships between them. While open, the Project Viewer continues to monitor the project's contents, automatically updating its display to reflect any changes in the project's component structure.

The Viewer maintains validation status for each LiveView component, and shows a red border around components to signal validation problems. Hover the mouse cursor over a component to see further a description of the validation issue.

The Viewer provides convenient access to the LiveView configuration or EventFlow module files that define each component:

  • Select a component, right-click, and select either Open LiveView Component or Open EventFlow Application as appropriate.

  • Double-click a component to open the LiveView Configuration Editor associated with it.

Opening the Project Viewer

The LiveView Project Wizard opens automatically under the following circumstances:

  • When you create a new LiveView project with File>New>StreamBase Project and select LiveView from the first screen. Clicking Finish opens the New LiveView Data Table wizard in which you can define your first table and its schema. When completed, the Project Viewer opens.

  • When you open New>Load StreamBase Sample, select one of the TIBCO Live Datamart samples, and leave the Open LiveView Project Viewer check box selected.

You can open the Project Viewer manually anytime:

  • Select a top-level project folder in the Project Explorer view, or select an lvconf file. Right-click and select Open LiveView Project Viewer.

    Remember that the Project Viewer displays a blank canvas for non-LiveView projects, or for LiveView projects that lack a Data Table (such as services-only projects).

  • In any non-Source tab of the LiveView Configuration Editor, click the Open LiveView Project Viewer link in the upper right.

Project Control Features

The LiveView Project Viewer provides a green Run button () in its upper right corner. Click this button to start the currently open LiveView project. The icons for Data Tables show a spinning disk animation while the project is starting, and show a green border when fully started.

To stop a running project, use the Terminate LiveView Fragment button () in Studio's top-level toolbar.

The Project Viewer supports adding, dropping, and starting LiveView Data Tables dynamically. To add a table while a project is running, invoke the context menu for the canvas as shown above. The New Data Table menu item is still present, even when the project is running.

To drop a table while a project is running, select a Data Table in the viewer, right-click, and select Drop Table from the context menu. Dropped tables lose their green border.

To start a dropped table, select its icon, right-click and select Start Table.

Invoking Wizards

The LiveView Project Viewer provides access to several wizards to help you create new projects and to add new features to existing projects. A Palette View is associated with the Viewer in the same lower left corner of Studio as the EventFlow Editor's Palette View.

You can start a wizard in several ways:

  • Double-click a wizard's icon in the Viewer's Palette View.

  • Right-click the Viewer canvas and select a wizard from the resulting menu.

  • With a Data Table selected, right-click and select Add from the context menu. This allows you to start the Data Source, Publisher, or Preprocessor wizards to connect one of these structures to the selected table.

  • From Studio's top-level menu, invoke File>New>Other and select one of the TIBCO LiveView wizards.

Wizard Descriptions

This section provides a brief overview of each wizard provided as companions to the LiveView Project Viewer.

Data Table
Data Source
Publisher
Aggregation
Transform
Preprocessor

Data Table

The New LiveView Data Table wizard is the first wizard you encounter when creating a new LiveView project.

Use page 1 to specify the table's schema, either by reference to a named schema or by editing the schema grid directly.

Use page 2 to designate one or more primary keys, either by selecting an available field and clicking the arrow button, by dragging and dropping from left to right, or by double-clicking an available field's name.

Data Source

Use the New LiveView Data Source wizard to create a simple Data Source EventFlow application, capable of sending data to the specified table. For demonstration and test purposes, it can also create a Feed Simulation, based on the table's schema, to automatically generate random data for the table.

When you click Finish, the wizard opens the newly generated EventFlow application, with a note attached to remind you of the next steps. You can eventually replace the Feed Simulation adapter with whatever EventFlow logic is needed to feed your particular table.

Publisher

Use the New LiveView Publisher wizard to create a publishing EventFlow application that publishes data to one or more Data Tables.

Use page 1 to specify a name for your Publisher application and to select its containing project.

Use page 2 to select the data tables into which you want the data published. You can optionally specify a data provider:

  • None. Use this selection for a Publisher application that will obtain its data from an upstream EventFlow application or from a StreamBase adapter.

  • TIBCO EMS. Use this selection if your Publisher application will obtain its data from your site's TIBCO EMS message bus infrastructure. This selection borrows configuration and EventFlow settings from the Fault Tolerant Recovery using the EMS bus sample. Select the support recovery option to create a fault tolerant EMS Publisher application based on that sample.

    Selecting this option generates:

    • A set of Provider applications (one per Data Table) that manage the EMS connections.

    • A single Publisher application that provides the bridge between LiveView and the Provider applications.

  • TIBCO FTL. Use this selection if your Publisher application will obtain its data from your site's TIBCO FTL message bus infrastructure. This selection borrows its configuration and settings as above, including its support recovery option, from the Fault Tolerant Recovery using the FTL bus sample.

    In this case, a single Publisher application is generated. The Provider mechanism is configured by means of module parameters in the Publisher application.

  • StreamBase Feed Simulation. Use this selection to have your Publisher application obtain its data for demonstration and testing purposes from a StreamBase Feed Simulation. You can replace the Feed Simulation mechanism later in the development cycle.

Aggregation

Use the New LiveView Aggregation wizard to create an aggregation between two existing Data Tables. The starting Data Table is called the Base Table. Before running this wizard, create a new Data Table with a similar schema to the Base Table.

On the wizard's page 1, specify:

  • The Base Table from which data is aggregated.

  • The existing Aggregation Table into which data is aggregated.

  • The projection used to populate the Aggregation Table.

  • An optional predicate clause.

Use the Validate button to test your projection and optional predicate against the Base Table. Click Finish when the validation test passes with no errors.

Transform

Use the New LiveView Transform wizard to create a transformation application that takes data from a Source Data Table, manipulates it, and places it into Target Data Table. Both Source and Target tables must already exist in the project; create your Target table first, using the Data Table wizard.

The wizard creates a simple Transform application that passes data unchanged from the Source table through a null EventFlow Map operator and on to the Target table. Replace the Map operator with the logic needed for your particular transformation.

Preprocessor

Use the New LiveView Preprocessor wizard to create a preprocessor application that takes data from an EventFlow Input Stream, manipulates it, and places the results into the specified Target Data Table. The Target tables must already exist in the project; create it using the Data Table wizard before running this wizard.

The wizard prompts for the name of the Target table, then generates a simple EventFlow Preprocessor application that intercepts data flowing into your table, processes the data with a null EventFlow Map operator, and then passes it on to the table. Replace the Map operator with the logic appropriate for your particular table.